Installing the VMware vSphere Client 4.1 on Windows 10

By YellowOnline on Thursday 5 April 2018 11:43 - Comments (11)
Category: Other, Views: 6.224

Yes, some people still need to support customers with older ESX server.

Unfortunately, the VMware vSphere Client 4.1 does a check to see if the computer is at least Windows XP SP2 but does not recognise more recent Windows versions.


https://tweakers.net/ext/f/xNGrJMfRZaobG4AMky9k1S0P/full.png



VMware KB 2069264 has a solution for you: run VMware-viclient.exe in compatibility mode.

https://tweakers.net/ext/f/6SLwqLgHfcVH2jWAcmqcIMwI/full.png

Unfortunately, this no longer seems to work, at least in my 1709 build. Or it's because I use an older version of the 4.1 client, 258902. [Edit: apparently, version 925676 installs without all of this]

https://tweakers.net/ext/f/xNGrJMfRZaobG4AMky9k1S0P/full.png

The executable is a wrapper around an MSI. Let's get the MSI out: start the installation from the EXE, wait for the error and then go to your temporary directory %TEMP%.You should find a folder with the installer GUID and inside the MSI. Copy it elsewhere.

https://tweakers.net/ext/f/93ZfkLa1HujvtWQytbAgAhY5/full.png

Now try and activate compatibility mode directly on the MSI.

https://tweakers.net/ext/f/TJafd9fD2pWVRbFzw82ZAXbA/full.png

Bad luck, we still get another error.

https://tweakers.net/ext/f/2U8OzvJRWO2Z7ajcTvM1NWLW/full.png

It does hint at some kind of a permissions issue. So let's execute the MSI explicitly as an Administrator.

https://tweakers.net/ext/f/F8dON4kodUWjZmcu4DC8zVPS/full.png

Hurray!

https://tweakers.net/ext/f/DqKRK4LubwA9nAfdNJk2e7Rt/full.png

If all goes well ...

https://tweakers.net/ext/f/miW5Ql0MoJnSTDDsQyqSV9NJ/full.png

... you can finally enjoy a vintage ESX server again.

Volgende: Microsoft OneDrive does not run 29-07 Microsoft OneDrive does not run
Volgende: So how does my own network look? 17-03 So how does my own network look?

Comments


By Tweakers user Blokker_1999, Thursday 5 April 2018 13:33

Maar heeft de 5.5 client geen ondersteuning voor ESX4 servers?


By Tweakers user walteij, Thursday 5 April 2018 14:41

Ik kan me nog herinneren dat de VI client van ESX 3.5 niet geinstalleerd kon worden op een 64-bit OS. Dat was vrij eenvoudig op te lossen door de MSI aan te passen met Orca MSI.

*een kleine zoektocht verder en gevonden welke versie het was en hoe je dit ook weer kon oplossen

By Tweakers user YellowOnline, Thursday 5 April 2018 14:42

walteij wrote on Thursday 5 April 2018 @ 14:41:
Ik kan me nog herinneren dat de VI client van ESX 3.5 niet geinstalleerd kon worden op een 64-bit OS. Dat was vrij eenvoudig op te lossen door de MSI aan te passen met Orca MSI.

*een kleine zoektocht verder en gevonden welke versie het was en hoe je dit ook weer kon oplossen
Orca :+ Dat ken ik uit mijn verleden als packager. Dat is nog minder gebruiksvriendelijk dan wat ik hier schreef :) Nou ja, zo moeilijk is het ook niet, maar de lat ligt toch nog wat hoger.

By Tweakers user Reb87, Thursday 5 April 2018 19:51

Geweldig, dank voor het uitzoeken! :)

By Tweakers user Duumke, Thursday 5 April 2018 21:06

Wow... nooit gedacht dat er nog plekken zouden zijn waar van die oude software zou draaien. Ik hoop dat het geen productie meer is. Zelf zou ik het voor productie namelijk wel te spannend vinden om te gaan beheren. VMware stopt later dit jaar de support voor versie 5.5, dus wij zijn al druk aan het denken hoe we gaan migreren en naar welke versie.

By Tweakers user walteij, Friday 6 April 2018 08:30

Duumke wrote on Thursday 5 April 2018 @ 21:06:
Wow... nooit gedacht dat er nog plekken zouden zijn waar van die oude software zou draaien. Ik hoop dat het geen productie meer is. Zelf zou ik het voor productie namelijk wel te spannend vinden om te gaan beheren. VMware stopt later dit jaar de support voor versie 5.5, dus wij zijn al druk aan het denken hoe we gaan migreren en naar welke versie.
Waarom migreren als je kunt upgraden?
Als je toch een ESX cluster hebt, is dat een makkie.
Node 1 in maintenance mode, upgrade kun je doen via de update manager, of je doet een verse installatie, waarna je de ESX host weer aan je VCenter toevoegt. Host uit maintenance mode halen, en door naar de volgende. VMotion doet de rest wel voor je.
VCenter zelf upgraden is ook geen rocket science

By Tweakers user YellowOnline, Friday 6 April 2018 11:54

Duumke wrote on Thursday 5 April 2018 @ 21:06:
Wow... nooit gedacht dat er nog plekken zouden zijn waar van die oude software zou draaien. Ik hoop dat het geen productie meer is. Zelf zou ik het voor productie namelijk wel te spannend vinden om te gaan beheren. VMware stopt later dit jaar de support voor versie 5.5, dus wij zijn al druk aan het denken hoe we gaan migreren en naar welke versie.
Natuurlijk is dat productie :+

By Tweakers user |sWORDs|, Sunday 8 April 2018 15:45

YellowOnline wrote on Friday 6 April 2018 @ 11:54:
[...]


Natuurlijk is dat productie :+
Ik snap niet hoe dit rendabel kan zijn, deze systemen zijn maximaal Westmere (zuipen stroom) en mogelijk zelfs nog ouder en guest OS is maximaal Windows Server 2008 R2 (al drie jaar uit mainstream support).

By Tweakers user Reb87, Monday 16 April 2018 16:34

Ik heb deze oplossing eindelijk getest, maar helaas werkt het niet. Zodra ik in de installatie wizard op 'install' klik verdwijnt de hele installer. windows 10 1709 16299.371. ;(

By Tweakers user wibra, Monday 30 July 2018 10:22

Ik snap niet hoe dit rendabel kan zijn, deze systemen zijn maximaal Westmere (zuipen stroom) en mogelijk zelfs nog ouder en guest OS is maximaal Windows Server 2008 R2 (al drie jaar uit mainstream support).
Er zijn zat productie systemen die nog op 2000 of 2003 draaien.

In order to comment on this post you need to be logged in. Use this link to log in when you are already a registered user. If you don't have an account you can create one here.